[Vm-dev] squeak 4.1 no mouse pointer in ubuntu 10.04 - SOLVED

Wolfgang Eder edw at generalmagic.at
Fri May 14 18:09:30 UTC 2010

On 12.05.2010 13:59, K. K. Subramaniam wrote:
> On Wednesday 12 May 2010 01:20:21 pm Wolfgang Eder wrote:
>> one more data point:
>> while squeak is running (no visible cursor),
>> i switch to text (ctrl-alt-f1) and back to x
>> (ctrl-alt-f7), i get a big (approx 100x100)
>> cursor consisting of vertical white stripes
>> (looks kinda like bar code).
> looks like a xserver bug or misconfiguration. Look into /var/log/Xorg*log for
> any errors (look for lines with EE).
> Save your /etc/xorg.conf file and reset configuration with the command:
>     gksudo dpkg-reconfigure -phigh xserver-xorg
> HTH .. Subbu

i have finally solved the problem by
disabling the hardware cursor for the neomagic driver.
(there was no xorg.conf; i have attached to this
email the one i have created)
thanks to all who have helped!
-------------- next part --------------
Section "ServerLayout"
	Identifier     "serverlayout-id"
	Screen      0  "screen-id" 0 0

Section "Monitor"
	Identifier   "monitor-id"

Section "Device"
	Identifier  "device-id"
	Driver      "neomagic"
	Option "SWCursor" "True"

Section "Screen"
	Identifier "screen-id"
	Device     "device-id"
	Monitor    "monitor-id"
	DefaultDepth     16

More information about the Vm-dev mailing list