[Vm-dev] Cog problems

Igor Stasenko siguctua at gmail.com
Wed Jan 19 10:41:46 UTC 2011

I built new Cog by taking latest VMMaker-oscog.46 on MacOS

VM still crashing at some random point during running all pharo-core
image tests.

Once i were able to run w/o crash and found following failures:

MethodContextTest debug: #testClosureRestart

because actually this one:

MethodContextTest new privRestartBlockArgsNoRemoteTempsTest

i'm not sure if this is a compiler issue (maybe it shuffling the
temps) or because of Cog, which doesn't likes restarts like that :)

Sometimes passes, sometimes not
(try doing following in workspace):

| a b |

a := 'ab' copy.
b := 'cd' copy.
self assert: (a identityHash ~= b identityHash).
a become: b.
self assert: (a ~= b).
self assert: (a identityHash ~= b identityHash).

i'm not sure if this is a big issue.. afaik, #become: don't gives any
guarantees about copying identityhash.

P.S. yesterday i were able to successfully build Cog on linux using
cmake configs i generating. but it crashing at first #commonReturn
which is really weird :)

I tried multiple images, same result.
The crash happens in given loop:

			while (closure != GIV(nilObj)) {
					home = longAt((closure + BaseHeaderSize) +
(ClosureOuterContextIndex << ShiftForWord));
					closure = longAt((home + BaseHeaderSize) + (ClosureIndex << ShiftForWord));

Best regards,
Igor Stasenko AKA sig.

More information about the Vm-dev mailing list