[Vm-dev] Building OSProcessPlugin on macs
bert at freudenbergs.de
Thu Jul 7 17:13:57 UTC 2011
On 07.07.2011, at 17:00, David T. Lewis wrote:
> On Thu, Jul 07, 2011 at 02:30:13PM +0200, Igor Stasenko wrote:
>> On 7 July 2011 14:22, David T. Lewis <lewis at mail.msen.com> wrote:
>>> On Thu, Jul 07, 2011 at 05:36:51AM +0200, Igor Stasenko wrote:
>>> I am not saying that writing "self atexit: #sendSignalToPids asSymbol"
>>> is wrong, but you would be hard pressed to convince me that it is
>>> easier to read and understand.
>> well, it could be understood as passing a selector to perform it later..
>> needless to say, that such pattern are quite common in smalltalk(s),
>> for events, handlers , subscriptions etc etc
> That's a fair point.
I would like it best if only literal strings would be translated into C strings. Symbols should become identifiers.
If that policy cannot be adopted for some reason, I like Igor's "asCIdentifier" better than "asSymbol".
- Bert -
More information about the Vm-dev