[Vm-dev] Re: Having trouble with 4.2 on Linux

Levente Uzonyi leves at elte.hu
Wed May 25 08:35:22 UTC 2011

On Tue, 24 May 2011, Ken Causey wrote:


> testRand instance method.  However as soon as I finished typing
> '<cdecl:' I started getting debuggers popping up for every keypress
> related to parsing, I suspect having to do with Shout.  Yet I check the
> preferences and under Browsing Shout and syntaxHighlightingAsYouType
> (going from memory) are not enabled.  But in fact the syntax is being
> colored as I type.  I can't figure out how to stop it.  So I just type

I fixed this bug in the Trunk a few weeks ago. It was present in Shout 
since 2004 or so, but probably the error was simply ignored by some other 
part of the system.

> away and ignore the debuggers resulting in
> testRand
>   "Test rand"
>   <cdecl: int 'rand' ()>
>   ^self externalCallFailed
> and I try to accept that but it will not accept it insisting that there
> should be a return call type in the cdecl line even though I think I've
> typed one in there.  I also tried <cdecl: int 'rand' (void)> as I'm not
> sure which if either of these is correct, but the same result happens in
> both cases.

The error message is correct, you should specify the return type as long. 
There's no int type in FFI, probably because it's ambiguous (even in C) 
and unnecessary.


> Ken

More information about the Vm-dev mailing list