[Vm-dev] Illumos port

Andreas Wacknitz a.wacknitz at gmx.de
Sat May 5 06:44:20 UTC 2012

Am 05.05.2012 um 01:04 schrieb Colin Putney:

> Hi folks,
> As was mentioned in the Squeak Board minutes, I've been working on
> getting Squeak running on SmartOS. (SmartOS is a newish distribution
> of Illumos, which is a fork of OpenSolaris, which is apparently no
> longer open, now that Oracle owns it. Anyway, it's a flavour of
> Solaris.)
> Attached is a patch that lets me build the VM and open an image in a
> SmartOS zone.
> I ran into a few issues, which I'll detail below:
> 1) I tried to do a proper autoconf check for the existence of headers
> such as <sys/sockio.h> and <sys/ucontext.h>, but I ran afoul of very
> strange behaviour from the libtool script that my regenerated
> configure script created. (Geez, how many levels of code generation do
> these GNU guys think is healthy?) I was able to create the config.h
> file that I wanted, but then linking didn't work anymore. For now I've
> just used the __sun__ preprocessor definition (apparently
> automatically defined by the compiler) for conditional compilation.
> 2) It looks like the image runs ok, but when I try to connect a VNC
> client (SmartOS has no GUI), the VM receives a SIGPOLL/SIGIO signal
> and exits. Fixing that probably requires more significant changes than
Maybe this has something to do with what I found out a few years ago:

> I've made so far, so if anybody has suggestions on how to tackle it,
> I'd love to hear them.
> If there's some other method of submitting the patch that would be
> more convenient of the maintainers, I'm happy to do that instead.
> Colin
> <solaris.patch>

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4819 bytes
Desc: not available
Url : http://lists.squeakfoundation.org/pipermail/vm-dev/attachments/20120505/a4e6af86/smime-0001.bin

More information about the Vm-dev mailing list