[Vm-dev] Re: I need help building Cog on 64bit Linux (new Squeak server)

Ken Causey ken at kencausey.com
Sat Jan 26 23:37:53 UTC 2013

On 01/26/2013 04:31 PM, Ken Causey wrote:
> On 01/26/2013 04:02 PM, Ken Causey wrote:
>> On 01/26/2013 03:50 PM, Ken Causey wrote:
>>> The problem I'm running into now is with building BochsIA32Plugin:
>> And a little more careful reading would have indicated that this is
>> because I missed a step. Well, no, I don't really have any need for the
>> Cog VM simulator. So how do I disable building this plugin? Do I need to
>> run VMMaker?
>> Unless I'm misunderstanding it seems like a mistake to me to have that
>> plugin built by default. But then I guess I am building from development
>> (SVN) sources.
>> Ken
> I'm still hoping there may be something a little simpler than using
> VMMaker and regenerating the source but while I wait for a response I
> decided I could at least take a look. First it should be noted that the
> instructions in HowToBuild are a bit out of date referring to files
> http://www.squeakvm.org/svn/squeak/branches/Cog/image/VMMaker-Squeak4.1.changes
> http://www.squeakvm.org/svn/squeak/branches/Cog/image/VMMaker-Squeak4.1.image
> when apparently
> CogTrunk43.images and CogTrunk43.changes are apparently the current
> files in SVN. No?
> I ran that and tried VMMaker generateConfiguration but this ran into an
> MNU for UnixFileDirectory>>pathFromURI: (in VMMaker
> class>>generateCogVM) which in fact is not defined in this image.
> I'm looking into it myself but any available assistance would be
> appreciated.
> Ken

First a correction s/VMMaker class>>generateCogVM/VMMaker 

I worked around the pathFromURI: issue by replacing it with fullNameFor: 
which seems to fit the bill.

But now I'm running into one that's bit more of a challenge for me.  In 
CCodeGenerator>>addMethodFor:selector: there is 'VMClass getVMMaker'. 
VMClass class>getVMMaker contains a bit of exception system trickery 
which I'm still trying to grok.  But the current symptom is that this 
returns nil and trying to send #cogitClassName to nil doesn't get very far.


More information about the Vm-dev mailing list