[Vm-dev] Adding -DNoDbgRegParms= to mvm solves my compile problem on linux

Eliot Miranda eliot.miranda at gmail.com
Mon Nov 17 16:41:49 UTC 2014

On Mon, Nov 17, 2014 at 8:40 AM, gettimothy <gettimothy at zoho.com> wrote:

> Hi Eliot,
> After searching this morning, I got nuffin.
> I have tried Unset CFLAGS in the mvm before the confugure call.
> I have tried using the CPPFLAGS (c-preprocessor flags) to set the
> -UNoDbgRegParms and no go there either.

Instead of working at a high level dive down to try and localise the
problem.  You can use /lib/cpp directly with a simple test case to try and
identify the bug.

> I am going to put his aside and move on to the CMAKE stuff.
> I needed to get this solved in the autotools suite to eliminate my CMake
> code as a source of error.
> While the auto-tools error is not solved, I am able to move back to CMake
> with some confidence. I need to ramp back up on what I was doing there.
> If I run into anything, I will pass it along.
> thx.
> tty

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/vm-dev/attachments/20141117/f2428d5a/attachment.htm

More information about the Vm-dev mailing list