[Vm-dev] Can't build current #3262 cog vm on ubuntu 14 vmware hosted system

gettimothy gettimothy at zoho.com
Tue Feb 24 15:47:55 UTC 2015

On Slackware, I have had to add tell the preprocessor where to find the x libraries. I do that with by adding the --x-libraries flag to  the mvm file in the build directory:

test -f config.h || ../../../platforms/unix/config/configure --without-npsqueak --without-vm-display-fbdev --without-gl --x-libraries=/usr/lib \



---- On Mon, 23 Feb 2015 18:18:38 -0500 tim Rowledge <tim at rowledge.org> wrote ---- 

Last summer I was using a vmware hosted ubuntu 14.0.4 system to build vms for use in making the ARM cog stuff. Last week I tried to get back to that and I simply can’t make a working vm with the latest ~#3600 code. 
The normal vm builds but won’t find the x11 display module - although it does seem to be able to find the null display. Not so terribly helpful though. Obviously the first thing I tried was building a debug vm to see if I could work out what is wrong but that won’t even come close to building. The log is full of exciting things like - 
/mnt/hgfs/tim/Documents/Squeak/Rasbian-VM/Pi-CogVM/Cog/src/vm/gcc3x-cointerp.c:579:13: note: previous declaration of ‘markStackPageMostRecentlyUsed’ was here 
 static void markStackPageMostRecentlyUsed(StackPage *page) NoDbgRegParms; 
/mnt/hgfs/tim/Documents/Squeak/Rasbian-VM/Pi-CogVM/Cog/src/vm/gcc3x-cointerp.c:18573:1: error: conflicting types for ‘markStackPageNextMostRecentlyUsed’ 
 markStackPageNextMostRecentlyUsed(StackPage *page) 
and later in the log - 
/mnt/hgfs/tim/Documents/Squeak/Rasbian-VM/Pi-CogVM/Cog/src/vm/gcc3x-cointerp.c:579:13: warning: ‘markStackPageMostRecentlyUsed’ used but never defined [enabled by default] 
 static void markStackPageMostRecentlyUsed(StackPage *page) NoDbgRegParms; 
To extra check, I tried the stack vm as well; same problems. 
Just to make life really amusing, the Raspbian system builds from the very same files without any problems, both plain and debug. I know it’s the same files because both unix systems mount the directories off my iMac. 
I’m at a loss to see why this is happening. Sure, different compilers with different bugs etc, but really? 
tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim 
Useful random insult:- Ready to check in at the HaHa Hilton. 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/vm-dev/attachments/20150224/d53b335e/attachment.htm

More information about the Vm-dev mailing list