[Vm-dev] Freeze after Morph Activity

Juan Vuletich JuanVuletich at zoho.com
Tue Feb 7 00:42:48 UTC 2017

On 06/02/2017 01:17 p.m., Bert Freudenberg wrote:
> On Sat, Feb 4, 2017 at 7:09 PM, Dan Norton <dnorton at mindspring.com 
> <mailto:dnorton at mindspring.com>> wrote:
>      Hi Folks,
>     On Debian8, using cog_linux64x64_squeak.cog.spur_201702021058 and
>     Cuis5.0-3040-spur-64 updated to 3043, everything will stop,
>     including the clock in the Cuis task bar. Neither mouse nor
>     keyboard events are processed. Trying to interrupt with alt-. is
>     unsuccessful. CogSpur was re-cloned and the test case was re-run
>     with the same result.
>     On Windows 10, using cog_win32x86_squeak.cog.spur_201702021058,
>     and Cuis 5.0 3043, the same test case runs for hours with no problem.
> Freezes on cog_macos64x64_squeak.cog.spur_201702021058 too. Maybe try 
> the 64 bit windows VM?
> - Bert -

Yes, we'd try that. I'm out of town, and will not be able to do it this 

If anyone wants to try, when I tried Spur64 in Windows the image would 
crash. The workaround is to clear the World background (an ivar in 
WorldState). There seems to be some problem with jpeg decompression on 
that VM.


Juan Vuletich

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/vm-dev/attachments/20170206/dc937d57/attachment.html>

More information about the Vm-dev mailing list