2012/2/3 Norbert Hartl <norbert(a)hartl.name>:
> Hi phillippe,
> What would be your idea how to solve this conflict? Thinking about it I don't find a solution to integrate both. I think at least one needs to step aside using method name prefix or the like. But maybe you have a _good_ idea how to solve it.
They should obviously not conflict. First I though one should be
renamed. However on second on thought wouldn't it be better to define
Magritte-Json in terms of Seaside-Json?
- make the argument of #jsonOn: a canvas like #renderOn: instead of a
stream (this removes the need for JSJsonStream)
- If we do all of this then we probably should move Seaside-Json from
addon to core
- While we're at it also move Seaside-REST to from addon to core
All of these things would apply to 3.1 only.