Ok… it’s the configuration and it was my fault: a leading space in the package name.

<repeat 10x> I should refrain from changing the version methods by hand </repeat 10x>

And I also fixed the Jenkins build that was not loading the Slime part (hence no failure).

Johan

On 05 Apr 2014, at 15:10, Johan Brichau <johan@inceptive.be> wrote:

I don’t think it has anything to do with the configuration itself.

I have the same load problem on Travis CI for Grease and not on the Jenkins CI

I’m also puzzled… but looking into it

On 05 Apr 2014, at 15:07, Esteban Lorenzano <estebanlm@gmail.com> wrote:

well… now mongotalk configuration fails: 


Fetched -> Magritte-Pharo3-Model-StephanEggermont.1 --- http://smalltalkhub.com/mc/Magritte/Magritte3/main/ --- http://smalltalkhub.com/mc/Magritte/Magritte3/main/
Project: MongoTalk stable [1.5.6]
Project: Grease stable [1.1.7]
...RETRY-> Grease-Slime-topa.26
...RETRY-> Grease-Slime-topa.26
...FAILED-> Grease-Slime-topa.26Could not resolve: Grease-Slime [ Grease-Slime-topa.26] in /var/lib/jenkins/jobs/rpg/workspace/package-cache http://smalltalkhub.com/mc/Seaside/Grease11/main/
MetacelloFetchingMCSpecLoader(MetacelloCommonMCSpecLoader)>>retryingResolvePackageSpecReferences:gofer:
MetacelloFetchingMCSpecLoader>>linearLoadPackageSpec:gofer: in Block: linearLoadPackageSpec: packageSpec gofer: gofer...
MetacelloPharo30Platform(MetacelloPlatform)>>do:displaying:
MetacelloFetchingMCSpecLoader>>linearLoadPackageSpec:gofer:
MetacelloPackageSpec>>loadUsing:gofer:
MetacelloFetchingMCSpecLoader(MetacelloCommonMCSpecLoader)>>linearLoadPackageSpecs:repositories: in Block: [ :pkg | pkg loadUsing: self gofer: gofer ]
OrderedCollection>>do:
MetacelloFetchingMCSpecLoader(MetacelloCommonMCSpecLoader)>>linearLoadPackageSpecs:repositories:
MetacelloFetchingMCSpecLoader>>linearLoadPackageSpecs:repositories: in Block: [ super linearLoadPackageSpecs: packageSpecs repos...etc...
BlockClosure>>ensure:
MetacelloLoaderPolicy>>pushLoadDirective:during:
MetacelloLoaderPolicy>>pushLinearLoadDirectivesDuring:for:
MetacelloFetchingMCSpecLoader>>linearLoadPackageSpecs:repositories:
MetacelloFetchingMCSpecLoader(MetacelloCommonMCSpecLoader)>>load
MetacelloMCVersionSpecLoader>>load
MetacelloMCVersion>>executeLoadFromArray:
MetacelloMCVersion>>fetchRequiredFromArray: in Block: [ :dict | ^ self executeLoadFromArray: anArray ]
MetacelloPharo30Platform(MetacelloPlatform)>>useStackCacheDuring:defaultDictionary: in Block: [ ^ aBlock value: dict ]
BlockClosure>>on:do:
MetacelloPharo30Platform(MetacelloPlatform)>>useStackCacheDuring:defaultDictionary:
MetacelloMCVersion>>fetchRequiredFromArray: in Block: [ ...
BlockClosure>>ensure:
MetacelloMCVersion>>fetchRequiredFromArray: in Block: [ ...
MetacelloPharo30Platform(MetacelloPlatform)>>do:displaying:
MetacelloMCVersion>>fetchRequiredFromArray:
MetacelloMCProjectSpec>>loadVersion: in Block: [ :dict | ...
MetacelloPharo30Platform(MetacelloPlatform)>>useStackCacheDuring:defaultDictionary: in Block: [ ^ aBlock value: dict ]
BlockClosure>>on:do:
MetacelloPharo30Platform(MetacelloPlatform)>>useStackCacheDuring:defaultDictionary:
MetacelloMCProjectSpec>>loadVersion:
Build step 'Execute shell' marked build as failure
Archiving artifacts
Recording test results
Sending e-mails to: estebanlm@gmail.com
Finished: FAILURE

honestly, we need to enhance the way we work with configurations… they are too weak. 
(it is not a complain against anyone, just an observation that becomes obvious day by day :P)

On 05 Apr 2014, at 09:58, Johan Brichau <johan@inceptive.be> wrote:

Hey Tobias,

Sorry that it took a while to pick up your fixes.

On 25 Mar 2014, at 14:09, Tobias Pape <Das.Linux@gmx.de> wrote:

Sadly builder-ci needs a small patch to cope for the fact that
the released 4.4 image still hast a redirect bug…

Is that the cause of the failures?
Because the Grease build on Travis shows the same failing tests.

It would be good if someone can fix them or tell me to mark some parts as non-loadable on Squeak (e.g. Slime in Squeak).
Otherwise, I will disable the automated builds as they are now always reporting a failure.

GREASE:
 I have fixed the only one Test that failed for me in Squeak 4.4 and Squeak 4.5.
 The fix is in Grease-Slime-topa.26. 
SEASIDE:
 Also here, only one test failed.
 The fix is in Seaside-Core-topa.811.

thank you!
They are now in version 3.1.1 of Seaside and version 1.1.7 of Grease.

:) Ok Fixes are in the STHub repo

Should https://github.com/dalehenrich/builderCI/pull/59 be accepted, please
add Squeak-4.5 to the test matrix :)

I will pull Dale.
He should emerge from the trenches any moment now :-)

thanks a lot!

Johan
_______________________________________________
seaside-dev mailing list
seaside-dev@lists.squeakfoundation.org
http://lists.squeakfoundation.org/mailman/listinfo/seaside-dev

_______________________________________________
seaside-dev mailing list
seaside-dev@lists.squeakfoundation.org
http://lists.squeakfoundation.org/mailman/listinfo/seaside-dev