Hi Peter,
As Mariano said above, what you probably want is to be able to run the 32 bit VM in your 64 bit Linux.
If this is the case, what you are probably missing is the 32 bit libraries, that you can install:

sudo apt-get install ia32-libs



On Mon, Oct 12, 2009 at 9:51 AM, Peter Osburg <nabble@peterosburg.otherinbox.com> wrote:

Hi list,

Ramiro Diaz Trepat-2 wrote:
> Is this the only way to get a 64 bit Linux VM?

I would like to raise the question again.

I tried to download squeak in a Debian with the mechanism described here:

Unfortunately I always get this message: "Failed to fetch
http://ftp.squeak.org/debian/dists/stable/main/binary-amd64/Packages.gz  404
Not Found"

Is there a simple way like using "apt-get update" to install the latest
64bit vm? I am not that familiar with Linux and I would prefer easy and
simple ways, though :D

Thanks in advance for any help.

Dave Woodward wrote:
> On Thu, Aug 6, 2009 at 6:38 PM, Mariano Martinez Peck <[hidden email]>
> wrote:
>     I fordward an email from someone having problems to compile squeakVM
>     ---------- Forwarded message ----------
>     From: Dave Woodward <[hidden email]>
>     Date: Thu, Aug 6, 2009 at 4:10 PM
>     Subject: [Pharo-project] Compiling a Squeak VM for Pharo on Ubuntu
> 8.04 LTS Server (64bit)
>     To: [hidden email]
>     I tried using the pre-compiled VM from the Pharo website to no avail.
>     I'm not exactly sure what the problem is, but when running the
>     pre-compiled Pharo VM, OR the pre-compiled Squeak 3.10-6 VM, they just
>     quit with a "File not found" error.  My only hunch regarding this is
>     that they were compiled on 32bit Linuxes, and I'm using a 64bit Linux.
>     I'm using a bare-bones install of Ubuntu server, 8.04LTS 64bit.  I'm
>     using Slicehost.com for a virtual server to run a Seaside application
>     (they use all 64bit *NIXs), and I'm switching from vanilla Squeak 3.9
>     to Pharo.
>     So, since the Squeak 3.10-6 VM didn't work either I decided to compile
>     my own VM.  This does not work out of the box on a vanilla Ubuntu
>     Server 8.04 install, so here are the steps I took to successfully
>     compile the VM from the 3.10-6 src files:
>     (cd /Squeak-3.10-6/platforms/unix)
>     Configure:
>     ./config/configure --without-x --without-gl --without-quartz
> --without-npsqueak
>     NOTE: The configure command adds 2 entries to disable the RomePlugin.
>     It looks like it first tests Freetype (not installed so adds an entry
>     to disable RomePlugin), and then tests Cairo (not installed, so adds
>     *another* entry to disable RomePlugin).  I believe the autoconf files
>     need to be fixed for this, but I leave it up to the squeak-dev folks
>     to figure that out as I have no knowledge of autoconf.
>     Make:
>     make squeak  (this will error)
>     To fix the damage from the note above, I had to remove the duplicate
>     entry for RomePlugin_exports on line 22 of disabledPlugins.c.
>     Make:
>     make squeak (should be successful)
>     make squeak install
>     move /usr/local/lib/squeak/3.10-6/UUIDPlugin to UUIDPlugin.bak as it
>     has the wrong ELF header, and I've heard has other problems too.
>     And now /usr/local/bin/squeak should work! (note, without X you'll
>     need to add "-vm display=none" for the VM to start).
>     I hope this helps people!  Thanks for everybody's hard work on Pharo!
>     Dave Woodward
>     ...................................................
>     www.futuremint.com
>     317.332.6438 | [hidden email]
>     _______________________________________________
>     Pharo-project mailing list
>     [hidden email]
View this message in context: http://n4.nabble.com/squeak-dev-Fwd-Pharo-project-Compiling-a-Squeak-VM-for-Pharo-on-Ubuntu-8-04-LTS-Server-64bit-tp83743p185757.html
Sent from the Squeak - Dev mailing list archive at Nabble.com.