2017-02-07 11:09 GMT+01:00 Nicolas Cellier <nicolas.cellier.aka.nice@gmail.com>:

2017-02-07 1:42 GMT+01:00 Juan Vuletich <JuanVuletich@zoho.com>:
On 06/02/2017 01:17 p.m., Bert Freudenberg wrote:

On Sat, Feb 4, 2017 at 7:09 PM, Dan Norton <dnorton@mindspring.com> wrote:
 Hi Folks,

On Debian8, using cog_linux64x64_squeak.cog.spur_201702021058 and Cuis5.0-3040-spur-64 updated to 3043, everything will stop, including the clock in the Cuis task bar. Neither mouse nor keyboard events are processed. Trying to interrupt with alt-. is unsuccessful. CogSpur was re-cloned and the test case was re-run with the same result.

On Windows 10, using cog_win32x86_squeak.cog.spur_201702021058, and Cuis 5.0 3043, the same test case runs for hours with no problem.

Freezes on cog_macos64x64_squeak.cog.spur_201702021058 too. Maybe try the 64 bit windows VM?

- Bert -

Yes, we'd try that. I'm out of town, and will not be able to do it this week.

If anyone wants to try, when I tried Spur64 in Windows the image would crash. The workaround is to clear the World background (an ivar in WorldState). There seems to be some problem with jpeg decompression on that VM.


Yes, jpeg is broken in Win64, but works fine in MacOSX 64 and Linux 64 with same sources.
I bet that it's related to LLP64...
I tired to update to latest available code for this jpeg library, but it does not fix anything (and would introduce controversial deviations to the standard).
We could comment out the generation of jpeg plugin in the interim

Follow-up: jpeg should be fixed for Win64 in latest builds on the server. It was not related to LLP64 but rather a problem of jump_buf alignment.