Hi Bernhard, Hi All,

On Sun, Nov 26, 2023 at 1:51 PM Bernhard Pieber <bernhard@pieber.com> wrote:
Hi Marcel,

Thank you for building the release candidate. I just used the squeak.cog.spur_macos64x64 VM with the latest Cuis image for several hours. When I tried to save and quit the VM it crashed, see attachment. It seems to have saved the image correctly before the crash.

The crash is in the Metal specific graphics backend:

5   AMDRadeonX6000MTLDriver             0x00007ffb0ab12d95 _ZL27GFX10_GenerateTileAddressesPK18CpuTexInterfaceRecPK21ATIMipmapBufferHeaderPKjjjjjjjjjjPFvyjjPvES7_ + 2730
6   AMDRadeonX6000MTLDriver             0x00007ffb0ab116c9 _ZL25GFX10_TextureReplaceTilesPK18CpuTexInterfaceRecPK21ATIMipmapBufferHeaderPKjPK21amd_gfx10_format_infojjmjmmjjjjj + 296
7   AMDRadeonX6000MTLDriver             0x00007ffb0ab111af _ZL25GFX10_TextureAccessRegionPK18CpuTexInterfaceRecPFvS1_PK21ATIMipmapBufferHeaderPKjPK21amd_gfx10_format_infojjmjmmjjjjjESB_S4_S6_S9_jjmjmmjjjjj + 546
8   AMDRadeonX6000MTLDriver             0x00007ffb0ab10f24 _Z31amdMtl_HWL_TextureReplaceRegionPK18CpuTexInterfaceRecPK21ATIMipmapBufferHeaderPKjPK21amd_gfx10_format_infojjPvjmmjjjjj + 400
9   AMDRadeonX6000MTLDriver             0x00007ffb0abdf85c -[GFXAAMD_MtlTexture replaceRegion:mipmapLevel:withBytes:bytesPerRow:] + 510
10  Squeak                              0x00000001005120de -[sqSqueakOSXMetalView loadTexturesSubRectangle:] + 616
11  Squeak                              0x0000000100511c39 -[sqSqueakOSXMetalView drawRect:] + 144
12  MetalKit                            0x00007ff81ce68a06 -[MTKView draw] + 159

Without looking at this in a debugger we don't know whether the issue is the rectangle passed to loadTexturesSubRectangle: (derived from clippy, a global variable which might be wrongly initialized) or to do with the texture itself. Since a compaction is done during snapshot the display bitmap and the texture machinery might have got out of sync.  I've cc'ed Ronie, the author, and hopefully he'll be able to take a look.  Bernhard, is this reproducible?

I used OSProcess extensively to call md5 to calculate file hashes. I ran into a lot of OSProcess errors. Maybe the crash has something to do with this.


Am 21.11.2023 um 18:02 schrieb Taeumel, Marcel <Marcel.Taeumel@hpi.de>:

Hi all --

Please test this VM version (includes a small change log):

Choose your preferred platform. Focus on cog.spur flavors for 64-bit machines.

Thank you!


best, Eliot