[Seaside-dev] WABrush questionable namings

Gerhard Obermann obi068 at gmail.com
Mon Feb 25 20:02:58 UTC 2008


Some more questionable things!

WACollectionTag
list: aCollection    ............................................... it
should only assign the list ??
  aCollection ifNotNil: [ self addAll: aCollection ]

It would be nice to use always the same key for the attributes as the name
of the updating method.
If this is not always possible or useful there should be an accessing method
at least.
Some examples:
aString = 'columns' ifTrue: [theString := 'cols'].
aString = 'selected' ifTrue: [theString := 'checked'].
aString = 'maxLength' ifTrue: [theString := 'maxlength'].
aString = 'verticalAlign' ifTrue: [theString := 'valign'].
aString = 'character' ifTrue: [theString := 'char'].
aString = 'characterOffset' ifTrue: [theString := 'charoff'].
colSpan -> colspan
rowSpan -> rowspan
url -> src
altText -> alt
multipart -> enctype
...

but cellpadding and cellspacing => OK

cheers

Gerhard
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/seaside-dev/attachments/20080225/7206153a/attachment.htm


More information about the seaside-dev mailing list