Spoon 3 beta 5

Chris Muller asqueaker at gmail.com
Wed Mar 5 03:05:33 UTC 2014

On Tue, Mar 4, 2014 at 4:50 AM, Craig Latta <craig at netjam.org> wrote:
> Hi Chris--
>> Congratulations on beta 5.
>      Thanks!
>> I tried it on Ubuntu.  FYI, I got a couple of strange messages when
>> unzipping about a couple of the files in there.
>      Oh, what did you get?

Ok, this might actually be a bug with Ubuntu's Archive Manager.  When
I open "Spoon 3 beta 5.zip" and then drag those two main folders into
a real folder, a box pops up with these messages:

caution: filename not matched:  Spoon 3 beta
5.app/Contents/Resources/Spoon 3 beta 5 processor.app/Icon\^M
caution: filename not matched:  __MACOSX/Spoon 3 beta
5.app/Contents/Resources/Spoon 3 beta 5 processor.app/._Icon\^M

However, when I simply used the "Extract" button on Archive Manager, I
got no errors.  Strange.

This time, after successful extraction, it opened the same web page as
before, and this time it didn't crash.  I was able to refresh the
page.  Clicking on "development environment" brought me to a totally
blank page.  The background window could not be closed with the X, I
had to kill the process from command-line.

>> Then i simply cd'd into the "Linux" folder and ran ./start.sh. I
>> think I saw a window open briefly...
>      That's a Squeak window; I try to open it headlessly, but
> something's wrong with that. What's the correct invocation?

Argument "-vm display=none" (without quotes of course) has worked for
me in the past.

>> ...but it was quickly covered by a new browser window that opened
>> [http://localhost:8090/README.html].
>      Cool! That's all I'm trying to get to work on all host platforms at
> the moment. Can you reload the page in the web browser?

Yes, reloading the page worked.

>      thanks again,

Thanks, looking forward to beta 6.  :)

More information about the Spoon mailing list