[Bug] SmartRefStream >> restoreClassInstVars

Mark Wai mwai at ibm.net
Thu Dec 10 02:19:23 UTC 1998

Missing block in the method.  This is only a minor bug but it does cause
runtime.  Attached file should fix it.  This bug was identified while I am
debugging the save morph problem.

After you file-in this fix, it should fix _part_ of load morph problem that
I described in my other post.

The remaining one involves quite a few different morphic classes and I am
still debugging it.  To repeat the scenario:

1)  Open a new morphic project
2)  Enter it
3)  Open up the pop up menu and choose 'keep this menu up'  (this is the key)
4)  Open a workspace
5)  Save the morphic project (changes -> save world as morph file)

In my experiment, it generate a file that is over 1M is size for such a
simple project! (and I have tried many time with same result)  Whereas if
you don't keep the menu up (in step 3), the size will dramatically down to
9K.  No clue at this point.

And when you quit the image, bring a clean image up, open up a file list,
select 'load as morph' on the file saved in the previous step, then debugger
comes up complaining a variety of different things.  I already patched a
number of fixes in my own image but I haven't completely fix the problem yet.


Attachment converted: Anon:SmartRefStream-restoreClassInst 
(TEXT/MSIE) (00005194)
Mark Wai
Wator Innovision
mailto: mwai at ibm.net or:[ mwai at frontiersa.com ]

More information about the Squeak-dev mailing list