Bug when opening Transcript

William O. Dargel wDargel at shoshana.com
Wed Jun 3 23:41:06 UTC 1998

sqrmax at cvtci.com.ar wrote:

> I left a Transcript open while updating from the web... man... that was
> some experience! I left the text on it and minimized it.

I ran into this as well. It must be a problem only if the Transcript is
collapsed while getting the updates. (Previously, I've watched the
updates logged in the Transcript as they happen).

> I've just tried to open it up, it shows up but no text is visible and
> Squeak gets into an infinite loop or something of the sort. I can debug, but after
> that I can't do anything else other than crash Squeak (by closing it without
> saving) and load the image again.

I found that closing the offending Transcript works to get you out of
the mess. Find the StandardSystemController in the debugger and do "self

> So here's the debug.
>     [snip]

The thing that caught my attention is that it looks like the instance
variables of the Paragraph had become inconsistent. (In my case) The
"text" had a string with only two lines, whereas "lines" showed 4
TextLineIntervals and "lastLine" was 4. Does this point to a basic
problem with TransciptStream's use of Paragraph, or is my understanding
of Paragraph off?

It seems as though the recent changes for pluggable views has left the
Transcript with a few loose ends. For instance, another thing I just
noticed about the Transcript is that selecting anything from the
"more..." menu item gives "Message not understood:

Bill Dargel            wdargel at shoshana.com
Shoshana Technologies
100 West Joy Road, Ann Arbor, MI 48105  USA

More information about the Squeak-dev mailing list