2.3 VMs do NOT hang on 68K (was Re: [BUG] 2.3 VMs hang on 68K)

Mark Guzdial guzdial at cc.gatech.edu
Tue Feb 23 21:34:28 UTC 1999

Thanks, John and Bruce!  The CFM-68K was what I needed.  Squeak 2.3 68K now
runs on my 190cs.

I have not yet been able to get Squeak 2.3b to execute correctly, though.
It halts with "QuickTimeLib not found".  I've reinstalled QuickTime 3.0
twice, the second time after deleting all of QuickTime, first.  I am
running OS 7.6.1, which may be the problem.  I'm trying to upgrade to
System 8.1 now.


At 8:50 AM -0800 2/23/99, johnm at wdi.disney.com wrote:
>Mark and Pat,
>The 2.3 VM's run under the 68K "Code Fragment Manager" (CFM). This
>had to be done in order to handle shared libraries on the 68K Mac,
>and shared libraries are how we implement pluggable primitives.
>Apple simply does NOT support running 68K-CFM applications
>under emulation on PowerPC Macs. Annoying, but that's
>the way it is.
>On a 68K Mac, you have to have the right version of the
>"CFM-68K Runtime Enabler" extension in your system folder.
>The version that I know works is 4.0 (424148 bytes). It's available
>on the Apple website somewhere, or I can send you a copy.
>When I first tried to get the new CFM version of the 68K
>VM going, I had an older version of this extension
>and the VM wouldn't start. It tooks me several weeks to
>finally ferret out the answer in an obscure Apple
>release note.
>Good luck! Please report to the Squeak list if you get
>it working, since others may be having problems.
>	-- John
>Mark Guzdial <guzdial at cc.gatech.edu> wrote:
>> >Subject: [BUG] 2.3 VMs hang on 68K
>> >Date: Mon, 22 Feb 99 10:34:55 -0800
>> >x-sender: pat_caudill at mail.instantiations.com
>> >From: Pat Caudill <Pat_Caudill at instantiations.com>
>> >To: "Mark Guzdial" <guzdial at cc.gatech.edu>
>> >
>> >I can't get either 2.3 or 2.3b 68K VMs to run on my Powerbook 190cs (68040
>> >based), even with no extensions on.  I was having problems running the 68K
>> >VMs on my G3 -- I thought that they should (via the 68K emulator), but I
>> >chalked it up to non-backwards-compatibility. But now that I've tried on
>> >an
>> >actual 68K box, I'm quite sure that it's the VMs.
>> >
>> >I haven't tried this but from my experiences with Smalltalik/V macintosh.
>> >These systems use (or emulate) the 68lc040 chip. That chip does not
>> >include the floating point instructions. The macintosh libraries will
>> >automaticly switch to the software floating point unless the program is
>> >compiled to directly include floating point instructions. Is it possible
>> >that this occured for one or more of the compiles when the VM was built?
>> >
>> >Pat Caudill
>> >patc at instantiations.com

Mark Guzdial : Georgia Tech : College of Computing : Atlanta, GA 30332-0280
(404) 894-5618 : Fax (404) 894-0673 : guzdial at cc.gatech.edu

More information about the Squeak-dev mailing list