can't file-in a project?

Bert Freudenberg bert at
Mon Sep 11 07:42:58 UTC 2000

On 10 Sep 2000, Randal L. Schwartz wrote:

> 9) select "file in as project"
> And oops... it tells me that an instance of my class is trying to be
> created, but the class is not defined. 

Happened to me, too, in my Speaklet example. I built it interactively, but
needed a very simple helper class. Storing and loading the project worked
fine, until I tried in a clean image :(

The problem is that the classes aren't stored in the project file. It
would be very difficult to determine what classes are needed, so that's
why they're just left out. What I did is to change my loader script to
file in the changeset before loading the project (see

> How can I recover my work?

Look at the "recently logged changes" in the "changes" menu, all hacking
you did is still there.

> * Should I be using changesets to hold my work instead of project-save/restore?

For coding, I use changesets. For "click-built" projects, I use project
save. I'm not too familiar with the other options yet ;^)

> * Can Morphic Projects be saved as a morph instead?

Yes, but it wouldn't change anything.

I think one could use the ImageSegment technology to store the classes
along with the project, though I don't know how. Alternatively, one could
make another item "save project and current changeset" that would automate
my process above.


-- Bert

More information about the Squeak-dev mailing list