Lost in Squeak world....

Ned Konz ned at bike-nomad.com
Mon Feb 12 21:39:47 UTC 2001


On Monday 12 February 2001 14:08, Rick wrote:

> Ok, guys, here you have. I filed out my subclass as it is right now. But to
> see the window in correct size ( if you are going to file in instead of
> just looking at it ) please make the following change in
> ModalSystemWindowView|doModalDialog  method ->
>           self resizeTo: model fullScreenSize.
>
> Thank you all for trying help me!  :-)

Well, some initial impressions:

* Editada (a global) will be clobbered every time you make a new one of 
these. I couldn't see any reason it should be a global, so I'd make it an 
instance variable called "editada".

* You shouldn't be calling changed: from the getter routines. For instance, 
fileString shouldn't call changed: (or be changing editada). This should be 
done from fileString: instead (which is called when the file name is changed 
by the user). Likewise with fileListIndex ; putting a changed: in there will 
not do what you want. Move the changed: calls to fileListIndex: instead.

You should know that these pairs of selected routines (a getter (selected) 
and a setter (changeSelected)) are called at different times. The getter is 
called every time the list has to be redrawn. If you want something to happen 
when someone clicks something, you have to put it in the setter.

* If you're going to be using the various filter blocks from 
PluggableFileList, you should probably be subclassing PluggableFileList 
rather than FileList, and using its instance variables for these blocks.

* If you're going to be using Morphic (not MVC), you would be better off 
coming up with your own version of openAsMorph, rather than open.

* Why did you rename fileListIndex to fileListIndx?
-- 
Ned Konz
currently: Stanwood, WA
email:     ned at bike-nomad.com
homepage:  http://bike-nomad.com





More information about the Squeak-dev mailing list