Mac OS X VM (was Re: New VMs)

Doug Way dway at
Thu Jun 28 17:24:42 UTC 2001

Speaking of OS X, I recently installed it at home (OS X final version).  I wanted to run Squeak on OS X, and I figured I'd try the Cocoa version for the true OS X experience.

So, to get the VM I downloaded and untarred Squeak3.0.1-MacOSX-VM.tar.gz, and it contained all the sources, but I just wanted the compiled VM so I then untarred the Frameworks subpackage as per the Readme instructions.  I tried double-clicking the resulting CocoaSqueak app (which had the correct Squeaky VM icon), but it only bounced for a second and didn't run.  (Also, it's only 60K or so which was odd.)  Drag-and-dropping an .image on it didn't work either.

I then realized I probably needed to move the Squeak.framework file into the framework search path, which the Readme mentions.  I tried moving it to the suggested directories (I had to create them both), but I'm not sure if they were actually in my framework search path.  (I checked my environment variables but didn't see one which looked like the right one.  Yes, I am a Cocoa newbie, but I'm familiar with Unix.)  Double-clicking the VM still didn't work.

Anyway, do all Cocoa apps need a separate .framework file?  (Or is it only needed for building a VM?)  It seems like a little bit of a hassle that this is necessary to run Squeak, since it's not needed on MacOS, Unix or any other Squeak platforms that I'm aware of.  Should I just stick to the Carbon version?

- Doug Way
  dway at

Henrik Gedenryd wrote:
> Giovanni Giorgi wrote:
> > Excuse  me, I am new to Mac Os X.
> > Can I use the carbon VM on Mac Os X?
> > Thank you!
> Yes, that is precisely the point of Carbon.
> It works well, with just a known glitch when switching apps in full-screen
> mode.
> Henrik

More information about the Squeak-dev mailing list