[BUG]TestRunner problem; RunArrayTest

Frank Shearar frank.shearar at rnid.org.uk
Thu May 13 08:41:00 UTC 2004

> >>> "Tim Rowledge" 05/12/04 23:36 >>>
> Strange problem(s) in TestRunner in a 5878+ image.
> After making some VM changes (I can open files multiple times
> - yahoo!)
> I ran the testrunner to give it a workout. Everything seemed
> to be okay
> up to RunArrayTest>testScanFromANSICompatability, whereit stopped. Not
> locked up, just stopped the test runner. It _claims_ to be still
> running and pressing the Stop button indeed behaves like it
> is stopping
> a running prog.  However, one can move the cursor around, scrollbars
> work and other tools can be opened. Very odd. Inspecting the model via
> the Halo debug menu shows that 'running' is a Process still in
> progress. Hmm, spawning Processes all over the place I see...
> Now looking at the code in this test, I can see why it ought to break
> (though I hav no clue why it is not locked up) - a
> non-completable loop
> is in progress in the second line of
> RunArratTest>testScanFromANSICompatability; RunArray
> scanFrom:(ReadStream on: '()a1death') cannot possibly complete since
> the scanner method is looking for a $; and there isn't one.
> Either the
> test is wrong, or the code is - and I would imagine that having a
> boundary condition that prevents ever completing a loop
> counts as a bug
> in most people's minds.
> I tried this out on my (spit) widows machine to make sure it isn't my
> new vm at fault. Same problem precisely.

The test is broken. See BFAV post ID 22160 for the bug report and 22161 for
the fix. (I posted both these messages to the list on 2004/04/28.)

But perhaps #scanFrom: should still check for the end of the stream and bail
out if the stream ends before a $; ?


More information about the Squeak-dev mailing list