Squeak 3.7 : Fails to load SqueakMap Package Loader

stéphane ducasse ducasse at iam.unibe.ch
Sat May 7 16:49:22 UTC 2005

Hi bert

Damien is a cool guy starting to learn Squeak in an hostile place :) I 
do not think that he wanted to insult people. Even if his tone was not 
the right one ;).

Anyway thanks for answering his questions because I could not. I got 
now a PC on my desktop so I should install soon a linux distro 
(gloops). What is the best distro to run squeak on it?

Damien let us know if this is working. Once you feel that you get a bit 
more control of squeak (monticello (read the pdf available on my 
smalltalk lectures), changeset, unit tests, sender, implementors), then 
let us know because you could start to play with SmallWiki 2. Since 
this is on SW2 that you will work when you will arrive at Berne.


On 7 mai 05, at 18:16, Bert Freudenberg wrote:

> Am 07.05.2005 um 15:11 schrieb Damien Cassou:
>> I'm afraid nobody seems to be interested in my problem. I do not think
>> you will have any better popularity if you don't mind other problems. 
>> It
>> works for you so why bothering ?
> You might have to learn a thing or two about open software. In 
> particular, that most people are in for it because it helps *them* 
> getting something done *they* need.
> I don't think insulting the people who might help you is the right 
> approach. (Btw, the right approach is outlined here 
> http://www.catb.org/~esr/faqs/smart-questions.html)
>> If I have a problem with Squeak, someone else may have the same 
>> problem.
> Sure. And since Squeakers are usually a very kind bunch of people, 
> someone might have pointed you to this thread:
>     http://discuss.squeakfoundation.org/cgi-bin/ezmlm-cgi?2:msn:47
> Or someone would have mentioned that the final Linux VM (3.7-7) 
> includes those fixes. Of course, not without telling you to always try 
> the latest VM before complaining.
> But alas, it seems nobody cares. Bad luck for you.
> - Bert -
>> Damien Cassou a écrit :
>>> Hi,
>>> every time I launched SqueakMap Package Loader I get an error
>>> "[BUG]UndefinedObject(Object)>>doesNotUnderstand: #do:". I have tried
>>> with 3.7 3.8 and 3.9 images. It appens a few seconds after I click
>>> "SqueakMap Package Loader" on the menu.
>>> I already have had this problem and you tell me to pass '-memory 
>>> 40m' to
>>> solve this. This worked until now.
>>> $ squeak -version
>>> 3.7b-5 #1 Tue Apr  6 20:36:57 CEST 2004 gcc egcs-2.91.66
>>> Squeak3.7beta of '1 April 2004' [latest update: #5868]
>>> Linux pingu.inria.fr 2.2.19-6.2.7 #1 Thu Jun 14 07:51:10 EDT 2001 
>>> i686
>>> default plugin location: /usr/local/lib/squeak/3.7b-5/*.so
>>> I'm running Debian Sid on GNU/Linux

More information about the Squeak-dev mailing list