copying class -> changes not recorded

Ross Boylan ross at
Mon May 9 00:44:00 UTC 2005

I made a copy of a class and started messing with the copy.  While I was
doing this, I noticed various symptoms consistent with an inability to
find the changes file:
1) comments and variable names were stripped from my code on accept
2) code was reformatted after I accepted it.
3) .changes file is not updating when I accept changes.
4) browser indicates there are no versions of methods.

Initially I noticed only some of these, and thought they were a result
of some preference I had set for pretty printing my code.  I did fool
around with that awhile ago, and don't recall exactly what I did.
However, I've tweaked everything I can find, and I've noticed that
changes to the original class do not have the same problems.  I tried
saving and exiting, but it didn't help (though it did verify my .changes
file is writable).

3.6 era image.  Any ideas what's going on?


P.S. One of a long line of things in squeak that hasn't worked for me
today.  Still trying to get layouts to do what I want... :(

More information about the Squeak-dev mailing list