[Q] Objective C Bridge status

Alain Fischer mailinglist.fischer at bluewin.ch
Thu May 12 20:30:54 UTC 2005

Hi Edgar,

I have never tried the bridge on 3.8 final.

Here are the info I write on another mail:

> I have just do the following and the plugin worked nice:
> - downloaded the UNIX VM 3.7-7 and 3.7 image
> - dowloaded http://beta4.com/~avi/ObjectiveCPlugin
> - copied the ObjectiveCPlugin in Squeak-3.7-7.app/Contents/MacOS/
> - downloaded 
> http://kilana.unibe.ch:8888/ObjectiveCBridge/ObjectiveC-avi.70.mcz
> - launched Squeak then installed ObjectiveC-avi.70.mcz
> After that in a Workspace a made a smalltest:
> "(NSString stringWithString: 'hello') uppercaseString"
> the result was "@'HELLO'"
> You ABSOLUTELY need to install the ObjectiveCPlugin.
> The one in the distributed VM is a very old one and will not work.

Le 12 mai 05, à 21:35, Lic. Edgar J. De Cleene a écrit :

> The thread about how connect to  the Mac OS X leads me to investigate 
> again
> Objective C Bridge
> The last what I have is ObjectiveC-avi.70.mcz
> Trying to test on 3.8 final , this complaint about
> SmartSyntaxInterpreterPlugin

If you want to load the package and build the plugin, you need to load 
first VMMaker.

> Avi, this mcz is yours ?
> Someone could give light about Objective C Bridge status and where the
> previous class are for download ?
> I thanks any lead.
> Edgar

Hope this help you in your investigation.


More information about the Squeak-dev mailing list