Squeak on Linux server

Franz Josef Konrad fjk at sava-systeme.de
Wed Nov 22 10:15:04 UTC 2006

Some days ago I had to install VMware Workstation on a linux root 
server. VMware Worsktation needs a X-server but my box even had no 
graphic card. So I've used the virtual X-Server xvfb and connected via 
VNC with X11vnc this box.

E.g. to start a xterm this way I did
/usr/X11R6/bin/Xvfb :1 -screen 0 1024x786x24 -fbdir /tmp :1
export DISPLAY=localhost:1; xterm &
x11vnc -display :1

and from remote connect with a VNC client my-ip-address:5900 to the 
virtual X-Server.

This should also run with Squeak but I haven't tried it.
Perhaps this helps you.

Franz Josef

Jimmie Houchin schrieb:
> Hello,
> I am wanting to try Squeak on my Ubuntu 6.10 i386 server. It has a
> simple basic server install which does not have xorg, alsa or any other
> such things.
> I am using the standard 3.9 unix vm.
> I have downloaded the headless seaside image and have tried to run it
> and get this:
> jimmie at elephant:#  squeak -headless HlessSeaside3.9-7067.image
> could not find module vm-display-X11
> Aborted
> What are my options?
> Any help greatly appreciated.
> Jimmie Houchin

More information about the Squeak-dev mailing list