Socket connection timeout...

kironsky at kironsky at
Sun Nov 26 20:22:59 UTC 2006


I am trying to connect to a server from Squeak 3.8.1#6747. It is the Robocup 
Soccer Server that by default opens the UDP port 6000 for connections. So I 
run the server and execute the following script in Workspace: 

s:=Socket newUDP.
s disconnect.
s connectToHostNamed: 'localhost' port: 6000. 

I get an exception telling me: "ConnectionTimedOut: Cannot connect to". The strange thing is, that if I run some sample clients for 
this server, they can all connect, so the port is surely opened (I checked 
it also with a port scanner). If I do not disconnect the port before 
connectiong, I get "InvalidSocketStatusException: Socket status must 
Unconnected before opening a new connection" exception. I checked my 
firewall settings, but neither adding UDP 6000 port to exceptions, nor 
disabling my firewall helped. I am running Fedora Core 5 x64 on an AMD 
Athlon 64 3200+ processor with 1GB RAM. Do you have any idea what can be the 
problem? I tried SocketStream class also but I get the same exception. 



More information about the Squeak-dev mailing list