[squeak-dev] InterpretSimulator

Jecel Assumpcao Jr jecel at merlintec.com
Thu Jan 22 19:56:41 UTC 2009

Eliot Miranda wrote:
> Hi Gwenael,
> > I've tried many times to use the simulator but every time it failed (missing
> > method, ...). Do you have a patch or a link to a functional release ?
> Not as yet.  I'm actively using the simulator in day to day development and
> depend on it so I have a reasonably complete functional simulator.  But
> before I can release it I have to get it vetted.  I'll try and get this done in the
> next couple of weeks.

Interesting - I was asking Craig about the simulator on the #squeak IRC
channel last week and he said that it should still work in recent
Squeaks, but I would need a fairly old image to load into it. My
impression had been that several times in the past the simulator had
been broken, which is what you guys are saying.

Let me test: in a 3.8-6665 image got a "sweep failed to find exact end
of memory" crash when trying to load itself. Trying to load the 1.1-APSL
image seemed to lock up, but then it also locks up a reasonably modern
VM. Loading a 1.16u image worked pretty well though the menus are all
black except for the selected option and quiting the simulated image got
me a primitive failure in shutting down the sound.

So running the simulator *in* 3.8 *with* a 1.16 image works, just as
Craig said. I'll try the simulator in a 3.10.2 image later and if that
works will see what is the most recent image it will simulate.

-- Jecel

More information about the Squeak-dev mailing list