[squeak-dev] Squeak and Linux OpenSuse 11.1

Bruce O'Neel squeak at pckswarms.ch
Mon May 18 15:27:02 UTC 2009


Try a  

ldd /usr/local/lib/squeak/3.10-4/vm-display-X11.so


ldd /usr/local/lib/squeak/3.10-4/vm-display-X11

and look at what libraries vm-disply-X11 wants.  That might point
you in some direction.



On Mon, May 18, 2009 at 03:20:45PM +0200, Giuseppe Luigi Punzi wrote:
> Hi all,
> Recently I installed OpenSuse 11.1 in my work machine, and I'm trying to get 
> Squeak working.
> I downloaded  Squeak-3.10-4.i686-pc-linux-gnu.tar.gz from 
> http://www.squeakvm.org/unix/
> I tried to launch ./INSTALL but it told me:
> "Your architecture appears to be: x86_64-linux-gnu.
> No binaries/libraries found for x86_64-linux-gnu.
> You might have tell INSTALL whch cpu-vendor-os to use."
> To avoid to build a VM, I forced with
> ./INSTALL i686-pc-linux-gnu/
> it installed, but, when I tried to start it, I get:
> glpunzi at dhcppc2:~/desarrollo/squeak.3.10> squeak Squeak3.10.2-7179-basic.image
> could not find display driver vm-display-X11; either:
>   - check that /usr/local/lib/squeak/3.10-4/vm-display-X11.so exists, or
>   - use the '-plugins <path>' option to tell me where it is, or
>   - remove DISPLAY from your environment.
> Abortado
> My vm-display.X11 looks like:
> glpunzi at dhcppc2:~/desarrollo/squeak.3.10> ls /usr/local/lib/squeak/3.10-4/
> AioPlugin                DBusPlugin       ImmX11Plugin   MIDIPlugin   
> OggPlugin        squeak          UnixOSProcessPlugin  vm-display-fbdev  vm-
> display-X11.do  vm-sound-NAS   XDisplayControlPlugin
> B3DAcceleratorPlugin     FileCopyPlugin   KedamaPlugin   Mpeg3Plugin  
> PseudoTTYPlugin  Squeak3D        UUIDPlugin           vm-display-null   vm-
> display-X11.so  vm-sound-null
> ClipboardExtendedPlugin  GStreamerPlugin  KedamaPlugin2  npsqueak.so  
> RomePlugin       SqueakFFIPrims  VideoForLinuxPlugin  vm-display-X11    vm-
> sound-ALSA      vm-sound-OSS
> glpunzi at dhcppc2:~/desarrollo/squeak.3.10>
> I had vm-display-X11 and I supposed about a symbolic link is needed, and I 
> create it (the vm-display-X11.so above is my symlink), but still don't 
> working.
> Someone could give me some advice?
> Cheers.

More information about the Squeak-dev mailing list