[squeak-dev] Re: bookmorph and ftp, anybody have this working?

Gary Dunn garydunnhi at gmail.com
Fri Jul 29 05:29:58 UTC 2011

Same result in Win7.

On Thu, Jul 28, 2011 at 11:24 AM, Gary Dunn <garydunnhi at gmail.com> wrote:

> This is one of those dumb brain freeze things that I hope will be easy to
> answer for someone already doing this.
> I am finishing up my how-to-make-a-book book and want to inclde a section
> on uploading to a server. To get started I thought I'd work out how to
> upload and download pages. Right off the bat I got an error.
> BookMorph>>getStemUrl fails at
> initial isEmpty
> ifTrue: [initial := ServerDirectory defaultStemUrl , '1.sp'].
> because ServerDirectory does not have the requested server in a Dictionary.
> When I look at that code it appears to be creating a random name, which is
> not what I want.
> According to some class comments (sorry, can't find then now) I should come
> up with my url, like ftp://server/folder/myBook1.sp and when I do Book
> menu "send all pages to server" I should select "Use page numbers" and paste
> in my URL. I never got the chance to paste in my URL.
> Back in
> getStemUrl
> "Try to find the old place where this book was stored. Confirm with the
>  user. Else ask for new place."
> | initial pg url knownURL |
>  knownURL := false.
> initial := ''.
> I changed the value of initial to my URL,
> initial := ''.
> Now I am asked for the URL, with that one filled in. But then I get a
> prompt for the password for nil. Naturally that failed. More reading class
> comments and code comments (thank goodness for those!) I discovered that I
> can add my username with a URL of 'ftp://gary@
> Almost there.
> I am prompted for the URL twice. After the second prompt I get the password
> prompt, then an error. My FTP server has replied 550 squeakftp: no such
> directory (or something similar).
> I can connect from the same host (my laptop running FreeBSD) using the
> command line FTP, works fine. I can also use gFTP. I even changed the
> permissions on the squeakftp folder to 777.
> I tried 'ftp://gary@' (the server
> is an iMac, so the full path is /Users/gary/squeakftp). Also 550.
> I tried 'ftp://gary@' but Squeak
> choked on the double slash -- asked for a second password for user nil. Not
> a problem.
> Any ideas why I am getting the 550 error?
> Note to self: try it from Windows instead of FreeBSD.
> --
> Gary Dunn
> Honolulu
> http://openslate.org/

Gary Dunn
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20110728/9148ce6b/attachment.htm

More information about the Squeak-dev mailing list