Closure VM on XO (was Re: [squeak-dev] Squeak/Pharo/Cuis on Android)

Casey Ransberger casey.obrien.r at
Fri Mar 4 01:38:57 UTC 2011

Is that Cog out of curiosity? I saw that awhile back when I ran it on
ubuntu. The classic VM worked fine though.

For some reason I want to think that the presence of .so is not significant
(i.e. I want to think it should work either way,) but for the life of me I
can't recall if anyone ever figured this one out. Many people could not
reproduce it. It may be environment or distribution specific. I wound up
dropping the linux laptop in favor of a Mac for other reasons, so I never
finished figuring out what the problem was.

On Thu, Mar 3, 2011 at 5:30 PM, Juan Vuletich <juan at> wrote:

> Juan Vuletich wrote:
>> Bert Freudenberg wrote:
>>> On 03.03.2011, at 14:54, Casey Ransberger wrote:
>>>> On Mar 3, 2011, at 2:26 PM, Juan Vuletich <juan at> wrote:
>>>>> I'm pretty close to a new release of Cuis that should feel way more
>>>>> responsive on slow devices. It does world redraw about 10 times faster when
>>>>> there are many windows open.
>>>>> Unfortunately I couldn't run it on my XO, as the preloaded VM is
>>>>> pre-closures... Does anybody know how to run a closures image on the XO?
>>>> I may be misunderstanding you; if not, you may experience a minor
>>>> facepalm. XO is Fedora-based, so you should be able to grab the Linux VM
>>>> sources and roll it up.
>>> The latest i386 Linux binary should just work:
>>> and maybe even Eliot's Cog binary. It's just another Linux machine ...
>>> - Bert -
>> It seems at least some Linux knowledge is needed... mine is almost nil :(.
>> I did as follows:
>> - Downloaded      Squeak-     and
>> from the link you gave.
>> - Decompressed the .tar.gz file
>> - Saved the .sh, the .tar.gz, and the uncompressed folder to a /Cuis/
>> folder in an sd card.
>> - Added cuis image, changes and sources to that folder
>> - Inserted the sd card on the XO
>> - Opened the Terminal activity
>> - su
>> - cd /media/*/Cuis
>> First try: Now, trying to run the installer (.sh) gives 'command not
>> found'. Executing Squeak-4*.sh results in the full name printed (i.e. found)
>> followed by: ': command not found'.
>> Ok. Let's try something different
>> - cd Squeak-* matches the folder name and changes current folder
>> - cd bin
>> - ls shows squeak and
>> - Now running 'squeak ../../imagename.image' gives 'This interpreter (vers
>> 6502) cannot read image file (vers. 6504)'
>> Looks like trying to run the original VM bundled with the machine. cp
>> squeak sqq to have it with some other name. doing 'sqq enter' gives 'sqq:
>> command not found'. cp to have this .sh with some other
>> name. doing ' enter' gives ' command not found'.
>> Looks like the machine doesn't want to run any binary from the sd card. I
>> guess there is some linux detail I'm unaware of... Please help me!
>> Thanks,
>> Juan Vuletich
> I guess I succeeded installing it. Now trying to run like this
> sh ../../imagename.image (in .../bin/) gives ' cannot
> open shared object file: No such file or directory / could not find display
> driver vm-display-x11; wither: / -check that
> /udr/local/lib/squeak/4.4.7-2357/ exists or / ...'
> There's no in the folder from the installation, but there
> is a so.vm-display... so copying this to have the '.so' at the end... Get
> the same error. I'm almost giving up.
> Thanks for any help.
> Juan Vuletich

Casey Ransberger
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Squeak-dev mailing list