Closure VM on XO (was Re: [squeak-dev] Squeak/Pharo/Cuis on Android)

Juan Vuletich juan at
Fri Mar 4 02:31:34 UTC 2011

Bert Freudenberg wrote:
> On 03.03.2011, at 17:30, Juan Vuletich wrote:
>> I guess I succeeded installing it. Now trying to run like this
>> sh ../../imagename.image (in .../bin/) gives ' cannot open shared object file: No such file or directory / could not find display driver vm-display-x11; wither: / -check that /udr/local/lib/squeak/4.4.7-2357/ exists or / ...'
>> There's no in the folder from the installation, but there is a so.vm-display... so copying this to have the '.so' at the end... Get the same error. I'm almost giving up.
> Well, you're almost there ;)
> You need either the tar.gz or the .sh, not both. After extracting, you can either install it, or run directly from where you installed it.
> The libGLU error you are getting now indicates the VM loads successfully. But the vm-display-x11 is linked to OpenGL. The XO has no OpenGL libraries installed. So what you need to do is copy the system's so.vm-display-x11 (from /usr/lib/squeak) to your new VM directory, overwriting the current version. Then everything should be fine. The system version was compiled without OpenGL support.
> - Bert -
Did that. Get same error as before...

Also tried the 'all in one' Cuis (based on Squeak's). The included .sh 
file does 'uname -m' to find out about the CPU. The answer on the XO is 
i586, not i686, and therefore 'all in one' can't run. I wonder if this 
would affect the stand alone linux vm, too...

Juan Vuletich

More information about the Squeak-dev mailing list