[squeak-dev] Installing Filetree

H. Hirzel hannes.hirzel at gmail.com
Thu Jul 19 14:25:31 UTC 2012

On 7/13/12, Dale Henrichs <dhenrich at vmware.com> wrote:
> Hannes,
> Could I see a little more of the stack to get some context?
> I should point out that I don't necessarily keep the mcz files up-to-date
> and that the complete install of FileTree should involve a load from a git
> repository[1], to get the absolutely latest code.
> I'd also be interested to know which version of the
> MonticelloFileTree-Core.squeak43 package that is loaded ...
> Finally I run tests using travisCI[2] for each push to github, but I test
> against the image downloaded from [3] (including latest github code for
> Squeak4.3 branch) and that passing all of the unit tests, with my latest
> updates...
> Dale
> [1]
> https://github.com/dalehenrich/filetree/blob/pharo1.3/doc/SqueakInstall.md
> [2] http://travis-ci.org/#!/dalehenrich/filetree/builds/1810028

> [3] http://ftp.squeak.org/4.3/Squeak4.3.zip


I redid the test case


A pristine copy of [3] using the latest Cog machine on Windows
http://www.mirandabanda.org/files/Cog/VM/VM.r2559/cogwin.zip (I assume
the Cog version has no influence, this is just for the record)

The image version is Squeak 4.3 #11860

1) Open a workspace
2) Paste in the code from the email from Bert who reports it has worked for him.

Installer ss3
        project: 'FileTree';
        install: 'MonticelloFileTree-Core.squeak43'.

3) Execute the code

A walkback.
The versions collection is empty, see attached screen shot.

Suggestions what else to test are welcome.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Squeak4.3AllInOneFileTreeLoadTestFailed.GIF
Type: image/gif
Size: 45936 bytes
Desc: not available
Url : http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20120719/c585edb6/Squeak4.3AllInOneFileTreeLoadTestFailed.gif

More information about the Squeak-dev mailing list