[squeak-dev] Best practices question

Chris Muller asqueaker at gmail.com
Wed Oct 23 18:09:35 UTC 2013


Kent Beck refers to the former as "Guard Clause" in his BP book and
agrees with you about when to use it.

I think it's good to only have returns at the top (guard clauses) or
bottom.  Not in the middle.


On Wed, Oct 23, 2013 at 9:12 AM, Louis LaBrunda
<Lou at keystone-software.com> wrote:
> Hi,
>
> I'm about to write a method where I need to test whether to do something or
> just get out.  What is the best practices way to do this?  For example:
>
> (a = b) ifTrue: [^nil].
> *The code that does the work*
>
> or:
>
> (a = b) ifFalse: [
>    *The code that does the work*
> ].
>
> I think the second is better style but I have used both.  Generally using
> the first when *The code that does the work* is long and the second when it
> is short.
>
> Is there any speed difference between them?  I doubt it but I thought I
> would ask anyway.
>
> Lou
> -----------------------------------------------------------
> Louis LaBrunda
> Keystone Software Corp.
> SkypeMe callto://PhotonDemon
> mailto:Lou at Keystone-Software.com http://www.Keystone-Software.com
>
>


More information about the Squeak-dev mailing list