[squeak-dev] Fixing the update stream for squeak45

Chris Muller asqueaker at gmail.com
Wed Nov 12 16:43:45 UTC 2014

I don't know what update # you tried to update from, but I just tried
it from a 13686 and it worked fine.

Try it after renaming / emptying your package-cache and I wonder if it
would work because that is where your empty mcz is...?

On Tue, Nov 11, 2014 at 8:43 PM, David T. Lewis <lewis at mail.msen.com> wrote:
> I tried updating a Squeak 4.5 image with the default squeak45 update stream
> (http://source.squeak.org/squeak45). The update fails and locks up the image,
> not a good impression for new users.
> The cause appears to be a corrupt copy of one of the MCZs in squeak45:
> -rw-r--r--  1 squeaksource squeaksource  72368 Feb  4  2014 squeak45/System-dtl.665.mcz
> -rw-r--r--  1 squeaksource squeaksource 903249 Jan 30  2014 trunk/System-dtl.665.mcz
> The one in squeak45 is empty when viewed in a Monticello browser. The one
> in trunk if fine.
> Presumably this was some sort of error introduced in copying the MCZ from
> trunk to squeak45.
> I will fix this by copying the good MCZ from trunk to squeak45 using a
> Monticello browser.
> Dave

More information about the Squeak-dev mailing list