[squeak-dev] Error when saving class comments

gettimothy gettimothy at zoho.com
Mon Feb 9 22:59:29 UTC 2015

This is could be the WriteStream>>nextChunkPut:aString "bug"

At the end of that method, put a 

self flush.

I just tested on a fresh Squeak4.6 image and that fix fixed the error for me. 



---- On Mon, 09 Feb 2015 09:55:06 -0500 Eliot Miranda <eliot.miranda at gmail.com> wrote ---- 

Hi Fabian, 
 what are the permissions on the changes file? What happens when you save a method? 
Eliot (phone) 
On Feb 9, 2015, at 5:41 AM, Fabian Windheuser <fabian.windheuser at student.hpi.de> wrote: 
> Hello, 
> Whenever I try to modify and save a class comment I get the following error: 
> "Error: RemoteString past end of file" (see the attachment for the error trace). 
> My changes are not getting saved and the file seems to get corrupted. I am no longer able to reopen this class comment because it always throws the same error. 
> I tried restarting my image and using new unmodified .image and .changes files however the error still occurred. 
> I am running Squeak 4.5 with update number #13702 on a 64bit Arch Linux distribution. 
> Best regards, 
> Fabian 
> <Error_RemoteString.png> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20150209/2d33f97e/attachment-0001.htm

More information about the Squeak-dev mailing list