[squeak-dev] Re: Error when saving class comments

Fabian Windheuser fabian.windheuser at student.hpi.de
Tue Feb 10 11:25:20 UTC 2015

Hey All,

The "self flush" at the end of  "WriteStream>>nextChunkPut:aString" fixed
the problem for me. It works as intended now.
Thank you very much!

On a side note for Eliot:
The changes file has sufficient permissions and all changes besides class
comments can be saved without a problem.


---- On Mon, 09 Feb 2015 17:59:29 -0500 gettimothy <gettimothy at zoho.com> wrote

>This is could be the WriteStream&gt;&gt;nextChunkPut:aString "bug"
>At the end of that method, put a
>self flush.
>I just tested on a fresh Squeak4.6 image and that fix fixed the error for

---- On Mon, 09 Feb 2015 09:55:06 -0500 Eliot Miranda &
lt;eliot.miranda at gmail.com&gt; wrote ----

Hi Fabian,

 what are the permissions on the changes file? What happens when you save a

Eliot (phone)

On Feb 9, 2015, at 5:41 AM, Fabian Windheuser &
lt;fabian.windheuser at student.hpi.de&gt; wrote:

&gt; Hello,
&gt; Whenever I try to modify and save a class comment I get the following
&gt; "Error: RemoteString past end of file" (see the attachment for the
error trace).
&gt; My changes are not getting saved and the file seems to get corrupted.
I am no longer able to reopen this class comment because it always throws
the same error.
&gt; I tried restarting my image and using new unmodified .image and
.changes files however the error still occurred.
&gt; I am running Squeak 4.5 with update number #13702 on a 64bit Arch
Linux distribution.
&gt; Best regards,
&gt; Fabian
&gt; &lt;Error_RemoteString.png&gt;
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20150210/3c0215c9/attachment.htm

More information about the Squeak-dev mailing list