Replace startUp with startUp: (was: Re: [squeak-dev] The Trunk: Kernel-mt.987.mcz)

Bert Freudenberg bert at
Fri Feb 5 14:30:33 UTC 2016

+1 for startUp: over startUp.

IMHO we should still keep Behavior>>startUp for the benefit of third-party packages.

On 05.02.2016, at 01:55, Chris Muller <asqueaker at> wrote:
> Every time I want to do something in start up or shutdown, I find I
> keep having to find examples and study these two methods; which calls
> which?  What's the default arg?  And does the "resuming" boolean mean
> the user pressed "Save" on the World Menu and resuming use of the
> image, or does it mean just launched from the OS..?

How about we rename the “resuming” variable to “starting” everywhere?

I just tried various names in snapshot:andQuit:withExitCode:embedded:, processStartUpList:, and startUp: and this seems to do the job pretty well.

> Anything that would make these more lucid would be welcome.


- Bert -

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4207 bytes
Desc: not available
Url :

More information about the Squeak-dev mailing list