[squeak-dev] Did the control key change somewhere along the way?

Bob Arning arning315 at comcast.net
Tue Nov 15 12:28:40 UTC 2016

The VM I was using refused to open an image it had saved, so I tried 
getting a newer VM. That solved the image open problem, but control keys 
no longer work as they once did. Any thoughts on restoring old behavior? 
(decades of muscle memory at stake ;-))

control key works in:

Virtual Machine
Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives 
VMMaker.oscog-eem.1405] 5.0
Mac OS X built on Jul  6 2015 19:01:28 UTC Compiler: 4.2.1 (Apple Inc. 
build 5666) (dot 3)
platform sources revision VM: r3397 
http://www.squeakvm.org/svn/squeak/branches/Cog Date: 2015-07-06 
11:56:39 -0700 Plugins: r3347 
CoInterpreter VMMaker.oscog-eem.1405 uuid: 
7aff388a-73ba-4202-bb5a-72b0759ff46b Jul  6 2015
StackToRegisterMappingCogit VMMaker.oscog-eem.1401 uuid: 
036f0933-639a-49dd-8a1d-a03bcdcb0a0a Jul  6 2015

control key does not work in:

Virtual Machine
/Users/bob/squeak/Squeak5.1-16548-32bit copy.app/Contents/MacOS/Squeak
Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives 
VMMaker.oscog-cb.1919] 32 bit
Mac OS X built on Aug 17 2016 18:59:49 UTC Compiler: 4.2.1 Compatible 
Apple LLVM 6.0 (clang-600.0.54)
platform sources revision VM: 201608171728 
https://github.com/OpenSmalltalk/opensmalltalk-vm.git $ Date: Wed Aug 17 
10:28:01 2016 -0700 $ Plugins: 201608171728 
https://github.com/OpenSmalltalk/opensmalltalk-vm.git $
CoInterpreter VMMaker.oscog-cb.1919 uuid: 
00a8dd2a-bc8d-4552-b400-be781c8aabec Aug 17 2016
StackToRegisterMappingCogit VMMaker.oscog-cb.1919 uuid: 
00a8dd2a-bc8d-4552-b400-be781c8aabec Aug 17 2016

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20161115/cba08f70/attachment.html>

More information about the Squeak-dev mailing list