[squeak-dev] [Pharo-dev] Pragma keyword / selector / methodSelector
dionisiydk at gmail.com
Tue Nov 15 21:08:52 UTC 2016
2016-11-15 21:58 GMT+01:00 Tobias Pape <Das.Linux at gmx.de>:
> Here's my 2ct:
> 1. Pragmas aren't actually pragmas. They do not instruct the compiler to
> do things (_except_ for primitive: and apicall:, but these are now
> They rather add metadata to a (compiled) method.
> 2. The 'thing' (ie, class) should probably be named
> 3. We can have the cake and eat it to:
> Rename Pragma -> MethodAnnotation.
> Make Pragma a new subclass of MethodAnnotation.
> Make MethodAnnotation implement
> #annotationSelector (or #selector, if it must be)
> Make Pragma implement
I remember long discussion about Pragma vs Annotation name where Igor won
completely :)). Conclusion was that Pragma is a right name.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Squeak-dev