[squeak-dev] Installing Seaside on Squeak

Tobias Pape Das.Linux at gmx.de
Mon Jan 9 20:01:17 UTC 2017


On 09.01.2017, at 16:27, Louis LaBrunda <Lou at Keystone-Software.com> wrote:

> Hi All,
> I want to install Seaside on Squeak (on windows for now).  The instructions for installing
> Seaside say to install Metacello first.  The instructions for Metacello say to run this
> snippet:
> Installer gemsource
>   project: 'metacello';
>   addPackage: 'ConfigurationOfMetacello';
>   install.
> But when I run the above snippet it fails with:
> UndefinedObject(Object)>>doesNotUnderstand: #binary
> I don't know how to copy more of the stack or I would include it here.  I did use the feature
> to send a bug report but I'm hoping someone can tell me how to get around this while the bug
> report is being looked at.

here are some observations:
first, I just tried the snippet in my Trunk image, and it worked.
second, I found your other post with the log file and the crash dump,
It seems things crashed when Squeak tried to _save_ the zip it just loaded[1].

Please see whether this goes away if you download this file
directly into the package-cache and maybe even load it from there.

Hope this helps

Best regards

PS: Yes, this actually should work. If it doesn't y'all allowed to hit me :D

[1]: Side note: It works like this:
    1. Download .mcz into squeak image
    2. Open (deserialize) .mcz into Monticello data
    3. For caching, serialize the Monticello data just deserialized into a _new_ .mcz in the package-cache directory.

> Thanks in advance for any and all help.
> Lou
> -- 
> Louis LaBrunda
> Keystone Software Corp.
> SkypeMe callto://PhotonDemon

More information about the Squeak-dev mailing list