[squeak-dev] sudo apt-get install NuScratch fails in 2017-09-07-raspbian-stretch-lite

Jecel Assumpcao Jr. jecel at merlintec.com
Fri Oct 20 21:00:15 UTC 2017

Louis LaBrunda wrote:
> I tried:
> sudo apt-get install scratch2
> that seems to find what it is looking for but I'm not sure it is what I should install and my
> code fails calling: GPIOAccessorPiGpio uniqueInstance with an externalCallFailed in
> PigpiodInterface.
> Am I installing the right thing?  Is something missing?  With jessie, pigpio and NuScratch,
> everything worked.

Scratch 2 is a different program written in Flash. And Scratch 3 will be
yet another program written in Javascript. But each version is supposed
to be able to load projects created by earlier versions, so these
changes shouldn't be too obvious to users. Unfortunately if you use
extensions then the difference will be very visible to you.

Note that the Raspberry Pi foundation has decided to move to Scratch 3,
so I would expect future versions of Raspbian to not include the Squeak
based Scratch.

-- Jecel

More information about the Squeak-dev mailing list