[squeak-dev] sudo apt-get install NuScratch fails in 2017-09-07-raspbian-stretch-lite

Louis LaBrunda Lou at Keystone-Software.com
Fri Oct 20 20:19:29 UTC 2017

Hi Jecel,

Thanks for the reply.  I have a Squeak/Seaside program that controls the GPIO pins.  Pre
raspbian stretch Squeak was present and I would install NuScratch to get some GPIO interface
code.  Now I install Squeak myself but I'm missing some GPIO stuff.  I'm not sure what I have
to load/install to get it.  I didn't realize what scratch2 was but hoped it was the NuScratch
stuff by a different name.

If Tim Rowledge is reading this, are you going to keep supporting your Squeak/Scratch code and
if so do you know what I need to get the GPIO stuff working?


On Fri, 20 Oct 2017 18:00:15 -0300, "Jecel Assumpcao Jr." <jecel at merlintec.com> wrote:

>Louis LaBrunda wrote:
>> I tried:
>> sudo apt-get install scratch2
>> that seems to find what it is looking for but I'm not sure it is what I should install and my
>> code fails calling: GPIOAccessorPiGpio uniqueInstance with an externalCallFailed in
>> PigpiodInterface.
>> Am I installing the right thing?  Is something missing?  With jessie, pigpio and NuScratch,
>> everything worked.
>Scratch 2 is a different program written in Flash. And Scratch 3 will be
>yet another program written in Javascript. But each version is supposed
>to be able to load projects created by earlier versions, so these
>changes shouldn't be too obvious to users. Unfortunately if you use
>extensions then the difference will be very visible to you.
>Note that the Raspberry Pi foundation has decided to move to Scratch 3,
>so I would expect future versions of Raspbian to not include the Squeak
>based Scratch.
>-- Jecel
Louis LaBrunda
Keystone Software Corp.
SkypeMe callto://PhotonDemon

More information about the Squeak-dev mailing list