[squeak-dev] sudo apt-get install NuScratch fails in 2017-09-07-raspbian-stretch-lite

Louis LaBrunda Lou at Keystone-Software.com
Mon Oct 23 15:26:09 UTC 2017

Hi Tim,

I'm sorry to bother you with this stuff but I think if you ever need to but a Raspbian lite
with the latest version you will run into the same problems.  With some help from you and a
little luck, maybe you won't have to go through what I'm going through.

It does look like

sudo apt-get install pigpio

Wasn't done but it is one of the first things I do when setting up a new version of Raspbian. I
had done it (I could see it in the terminal command stack) and I did it again just in case. No
joy.  Please don't feel bad and don't hesitate to suggest things any amateur should have tried.
When think don't work that should work, everything, no matter how simple or whatever, is in
question.  I tried your test and got what you expected.  I tried:

sudo pigpiod

just to see what would happen.  The response was:

2017-10-23 10:58:46 initInitialise: Can't lock /var/run/pigpio.pid
Can't initialise pigpio library

Does that tell us anything?

I also tried changing some of the settings via raspi-config that seemed to have anything to do
with gpio nothing changed.  Except after a reboot it would belch a lot of stuff on the monitor.
I would loose patients with that and turn the power off.  Upon booting again sometimes the
belching would repeat, others it would boot okay.

I will keep trying and let you know what happens.


On Sat, 21 Oct 2017 11:42:57 -0700, tim Rowledge <tim at rowledge.org> wrote:

>> On 21-10-2017, at 11:06 AM, Louis LaBrunda <Lou at Keystone-Software.com> wrote:
>> Hi Tim,
>> I installed the file from the link you gave me but still no luck.  I see the SqueakDebug log
>> attachment doesn't look very good so below are parts of it.  I still think I'm missing
>> something, drivers, an interface, something?
>My best guess is that you don’t have pigpio installed, which would make some sense for Raspbian lite. If you open a terminal and try 
>you should get something like
>2017-10-21 11:39:00 initCheckPermitted: 
>|Sorry, you don't have permission to run this program.    |
>|Try running as root, e.g. precede the command with sudo. |
>Can't initialise pigpio library
>back if it is installed. And if not, I guess you’d get some ‘command not found’ error.
>I’ve not needed to try it (my first installs were from source because it wasn’t in by default and then after that it was there by default) but I imagine installing pigpio would be 
>`sudo apt-get install pigpio`
Louis LaBrunda
Keystone Software Corp.
SkypeMe callto://PhotonDemon

More information about the Squeak-dev mailing list