[squeak-dev] source.squeak.org --- Responsiveness

Chris Muller asqueaker at gmail.com
Fri Jan 19 03:09:00 UTC 2018

>> I was able to VNC right into the server image.  It is responsive,
>> however, there are a ton of processes apparently stuck on a
>> Mutex>>#critical: block.  I think that explains the timeouts.
>> The service was last restarted 204 days ago.  I'll contact box-admins
>> and board about restarting the service, that should clear it up.
> and for my information what version of Squeak and what VM is it running?

The production VM released with Squeak 5.1.

    5.0-201608171728  Sun Sep 25 16:02:24 UTC 2016 gcc 4.6.3
[Production Spur VM]

It's been a few months since I tried the most recent VM.  All the
newer ones I'd ever tried since the GC rewrite would crash more often
than I could bear.

I run this same code base and VM to support my own code repository as
a local daemontools service.  It doesn't have the volume
source.squeak.org has, but it has been stable for me.

More information about the Squeak-dev mailing list