[squeak-dev] Error when installing OSProcess from SqueakMap

Chris Muller asqueaker at gmail.com
Sun Apr 14 23:07:14 UTC 2019

Hi Dave,

> I don't know what the issue is with the SqueakMap loading, but the
> 'head' scripts for OSProcess and CommandShell do this:

If you will click "edit releases" on your OSProcess, select that 14.8,
uncheck the "Published" box, no one will have that problem.

I think we had a discussion about the "Published" flag before and
generally agreed its not a very useful attribute and, in this case,
actually detrimental.

>   MCMcmUpdater updateFromRepository: 'http://www.squeaksource.com/OSProcess' .
>   MCMcmUpdater updateFromRepository: 'http://www.squeaksource.com/CommandShell'.
> These work fine when evaluated outside of SqueakMap, so I would suggest

They worked fine when loaded from SqueakMap, too.  It's the attempted
rendering of the list in SqueakMap UI where the different branches is

 - Chris

> doing that for the time being. I don't know what the issue when loading
> from the SqueakMap loader, sorry.
> Dave
> On Sat, Apr 13, 2019 at 05:20:07PM +0200, Bernhard Pieber wrote:
> > I tried installing OSProcess in a fully updated trunk image according to the installation instructions on http://wiki.squeak.org/squeak/708:
> >
> > "Use the latest version of OSProcess and CommandShell, and load both of them. Load both from SqueakMap. Please use the head (latest version) and ignore any Squeak version tags or warnings.
> > OSProcess and CommandShell are Squeak version independent, but there is no way to say that with SqueakMap."
> >
> > Here are the steps I took:
> > 1. I selected Apps > SqueakMap catalog.
> > 2. I clicked the Update button.
> > 3. I deselected "New safely-available packages" from the bottom-left list's context menu. (It took me quite a while to figure that out.)
> > 4. I expanded OSProcess in the top-left list and clicked on (head)
> > 5. I clicked the Install button.
> > 6. The following error appears:
> > "Error occurred during install:
> > Receiver and argument in different branches
> > Would you like to open a debugger?" (See the attached debug log for details.)
> >
> > The error seems to break SqueakMap. From now on it always opens when I try to open SqueakMap.
> >
> > - Bernhard
> >
> >

More information about the Squeak-dev mailing list