[squeak-dev] Installing various versions of squeaksource is problematic

tim Rowledge tim at rowledge.org
Fri Aug 23 21:35:40 UTC 2019

A while back I was asking about internal use monticello repositories and one suggestion I didn't have time to do much with was to install squeaksource; three options were pointed out

I thought I'd give it a quick try to see what happens. All in all it wasn't a particularly successful attempt.

A) squeaksource3
I know Tobias officially abandoned this at the beginning of the year but since there is an entry in squeakmap for it I thought "let's try it". Nothing happened. There was clearly an attempt to find a suitable version for the image I am using (a 5.2-18229 release, and an updated version) but nothing further.
I noticed Tobias had pointed out using 
`Metacello new configuration: 'SqueakSource3';
	load: #('All').`
... so I tried that; it failed because of not finding a suitable version. I dug a little but didn't see anything obvious. I also looked in the MetacelloRepository for a ConfigurationOf... but it appears to have been removed.

B) squeaksource
There's also a SqueakMap entry for the old system. It didn't load either. Complaints about no #stable version etc
I did see the ConfigurationOfSqueakSource and tried that but again, no stable version, no way I spotted to use any other named version that looked plausible. I suppose one shouldn't be too surprised since it is pretty old but it *is* the system we have as a main repository...

C) personalsqueaksource
This does seem to load from SqueakMap *but* not trivially. There is a syntax error in the Seaside2 method WAWikiRenderer>>#swikifyPiece: where the original was writing into a block arg (aLine, replaced with thisLine etc to make it complete). There is also an alarmingly large number of Undeclareds left over at the end of the load.

So, not a terribly happy test.

tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
Strange OpCodes: SDR: Shift Disk Right

More information about the Squeak-dev mailing list