[squeak-dev] Installing various versions of squeaksource is problematic

Chris Muller asqueaker at gmail.com
Thu Aug 29 02:29:23 UTC 2019

Hi Tim,

> C) personalsqueaksource
> This does seem to load from SqueakMap *but* not trivially. There is a
> syntax error in the Seaside2 method WAWikiRenderer>>#swikifyPiece: where
> the original was writing into a block arg (aLine, replaced with thisLine
> etc to make it complete). There is also an alarmingly large number of
> Undeclareds left over at the end of the load.

Since you didn't say, I don't know what you tried to install, or what image
level you tried to install it in, but I just verified that "Personal
SqueakSource", after all these years, _still_ loads cleanly without a
single hiccup into the image level designated by the SqueakMap entry -- 5.2.

So, not a terribly happy test.

A lot of work went into designing it to be easy to install and deploy on a
Debian/Ubuntu Linux.   I wish I knew what you tried to do to know where it
went wrong..

 - Chris

> tim
> --
> tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
> Strange OpCodes: SDR: Shift Disk Right
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squeakfoundation.org/pipermail/squeak-dev/attachments/20190828/6282f333/attachment.html>

More information about the Squeak-dev mailing list