[squeak-dev] Installing various versions of squeaksource is problematic

tim Rowledge tim at rowledge.org
Thu Aug 29 21:36:14 UTC 2019

> On 2019-08-28, at 7:29 PM, Chris Muller <asqueaker at gmail.com> wrote:
> Hi Tim,

> [snip]

> A lot of work went into designing it to be easy to install and deploy on a Debian/Ubuntu Linux.   I wish I knew what you tried to do to know where it went wrong..

Well as I said, it went fine except for that one Seaside method trying to write into a block arg. My notes say I tried the install on a plain 5.2 and an updated one with the same results, but since it is always possible I screwed up, let's do it again to try to be sure.

OK, interesting; a dead plain straight out of the zip 5.2-18299 does indeed load cleanly 
(though the asking for the user/password near the end jars a tiny bit). So what was the difference... well it *was* an 18299 image in the previous test but I did load my preferences file. Ahhh. OK, my preferences disables 'Allow block argument assignment' because, obviously, nobody would ever do that ;-) I must have set that and saved it quite some time ago.

Confusion resolved! I wouldn't say it was even worth 'fixing' the WAWikiRenderer>>swikifyPiece: method since it is from Seaside2 and hopefully there is some chance of a personalsqueaksource based on Seaside3 some time. Perhaps making the install script enable the block-arg-writing during the load might be worthwhile.

Thanks for doing that check-install; now to see if Raspbian will run the system...

tim Rowledge; tim at rowledge.org; http://www.rowledge.org/tim
Strange OpCodes: RP: Read Printer

More information about the Squeak-dev mailing list